[an error occurred while processing this directive] SamurAI Coding 2016-17 [an error occurred while processing this directive]






Software Environment of Online Execution

ant -version | head -n 1
=> Apache Ant(TM) version 1.10.0 compiled on December 27 2016

ceylon -v | head -n 1
=> ceylon version 1.3.1 74ea8c7 (Now We Try It My Way)

clang --version | head -n 1
=> clang version 3.8.1-12ubuntu1 (tags/RELEASE_381/final)

clisp --version | head -n 1
=> GNU CLISP 2.49 (2010-07-07) (built on toyol.buildd [127.0.1.1])

coffee -v | head -n 1
=> CoffeeScript version 1.12.3

dmcs --version | head -n 1
=> Mono C# compiler version 4.2.1.0

dmd --version | head -n 1
=> DMD64 D Compiler v2.073.0

erl +V 2>&1 | head -n 1
=> Erlang (SMP,ASYNC_THREADS) (BEAM) emulator version 7.3.1.2

gcc --version | head -n 1
=> gcc (Ubuntu 6.2.0-5ubuntu12) 6.2.0 20161005

gdc --version | head -n 1
=> gdc (Ubuntu 6.2.0-5ubuntu12) 6.2.0 20161005

ghc --version | head -n 1
=> The Glorious Glasgow Haskell Compilation System, version 7.10.3

g++ --version | head -n 1
=> g++ (Ubuntu 6.2.0-5ubuntu12) 6.2.0 20161005

go version | head -n 1
=> go version go1.6.3 linux/amd64

gosh -V | head -n 1
=> Gauche scheme shell, version 0.9.4 [utf-8,pthreads], x86_64-pc-linux-gnu

gradle -version | head -n 3 | tail -n 1
=> Gradle 3.3

groovy --version | head -n 1
=> Groovy Version: 2.4.8 JVM: 1.8.0_121 Vendor: Oracle Corporation OS: Linux

gst -v | head -n 1
=> GNU Smalltalk version 3.2.5

java -version 2>&1 | head -n 1
=> java version "1.8.0_121"

javac -version 2>&1 | head -n 1
=> javac 1.8.0_121

kotlin -version | head -n 1
=> Kotlin version 1.0.6 (JRE 1.8.0_121-b13)

llc --version | head -n 1
=> LLVM (http://llvm.org/):

lsc -v | head -n 1
=> LiveScript version 1.5.0

lua5.3 -v | head -n 1
=> Lua 5.3.1  Copyright (C) 1994-2015 Lua.org, PUC-Rio

make -v | head -n 1
=> GNU Make 4.1

mcs --version | head -n 1
=> Mono C# compiler version 4.2.1.0

mono -V | head -n 1
=> Mono JIT compiler version 4.2.1 (Debian 4.2.1.102+dfsg2-7ubuntu4)

mvn -v | head -n 1
=> Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T16:41:47+00:00)

node -v | head -n 1
=> v7.5.0

npm -v | head -n 1
=> 4.1.2

ocaml -version | head -n 1
=> The OCaml toplevel, version 4.02.3

python -V 2>&1 | head -n 1
=> Python 2.7.12+

python3 -V | head -n 1
=> Python 3.5.2+

perl -v | sed -n 2P
=> This is perl 5, version 22, subversion 2 (v5.22.2) built for x86_64-linux-gnu-thread-multi

php -v | head -n 1
=> PHP 7.0.13-0ubuntu0.16.10.1 (cli) ( NTS )

ruby -v | head -n 1
=> ruby 2.3.1p112 (2016-04-26) [x86_64-linux-gnu]

rustc --version | head -n 1
=> rustc 1.10.0

sbt about | head -n 4 | tail -n 1
=> [info] This is sbt 0.13.13

scala -version 2>&1 | head -n 1
=> Scala code runner version 2.12.1 -- Copyright 2002-2016, LAMP/EPFL and Lightbend, Inc.

swipl --version | head -n 1
=> SWI-Prolog version 7.2.3 for amd64

tsc -v | head -n 1
=> Version 2.1.5

xbuild --verison | head -n 1
=> XBuild Engine Version 12.0
      
[an error occurred while processing this directive]